Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

browse.conf trouble restricting to type in hierarchy

Hello,

This is an issue with Pawtucket2, we are currently on Providence v 1.5.

We have multiple hierarchical collection types including collection, series, subseries. In our front end Pawtucket2 instance, we are trying to set up the browse.conf file a browseType restricted to only the top level, "collection" type of collection, but the series and subseries types are still showing up in the browse (see screenshot). I think this is an issue with the hierarchy, because I am able to restrict to series, but those include subseries, and I can restrict to only subseries successfully, which is the lowest part of the hierarchy that we use. I tried "dont_include_subtypes = 1" and "hierarchy_limit = 1" without success. Is there any way to set up the configuration so that the browse only includes the top level of the hierarchy? I believe we had set this up successfully in the past, so I'm wondering if I might have inadvertently changed a hierarchy setting elsewhere that threw off this browse configuration.

Thanks for any thoughts or suggestions!





1482 x 1357 - 292K
2560 x 1386 - 491K

Comments

  • Hi Liza,

    There is a browse option called dontExpandTypesHierarchically = 1 that should restrict child elements from showing in your results.  However, this option was implemented after your site was installed, so it may not be available to you depending on when you last updated your front-end code.
  • It worked! Thanks so much, Sophie! (Sorry if this info was somewhere I should have been able to find it.)
Sign In or Register to comment.