Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Media import not matching existing object identifiers

edited March 14 in Troubleshooting

My installation (Providence 1.6.2) uses object identifiers of the form DSYHC.2003.2 or DSYHC.2003.4.1.

These object identifiers definitely exist in the database and I am now trying to do a bulk import of images to match up against these identifiers using appropriate filenames, e.g. DSYHC.2003.2.jpg and DSYHC.2003.4.1.jpg.

The files are correctly located in the import directory (see attached image).

When I run the batch import I get an error message to say that each image was skipped because it couldn't be matched (also see attached image)

My import settings are as below (and in the attached image)

  • Import Mode = Import only media which can be matched with existing records
  • Object Identifier = Set object identifier to file name without extension

I believe everything is named and configured correctly on the media import page so am now not sure what I am missing.

Thanks for any help.


717 x 361 - 51K
846 x 359 - 83K
760 x 663 - 99K


  • edited March 20
    Still no luck with this. Does anyone have any thoughts on what might be going on? Thanks
  • Do I need to modify a regex expression in a configuration file somewhere to make a successful match?
  • Most likely you do. What modifications are required will depend upon the structure of the filenames on the files you're importing.
  • edited March 22

    Hi Seth. the structure of the filenames and the configuration is in the original post.

    e.g. filenames of media are DSYHC.2003.2.jpg, DSYHC.2003.4.1.jpg, etc.

    Existing idnos in the database are the same as these but without the extension, e.g. DSYHC.2003.2, DSYHC.2003.4.1

    I thought this would have matched without any problem when "Object Identifier = Set object identifier to file name without extension"

    Is that not the case?



  • From what I can see the standard regex in app.conf should work fine with the above examples for matching against filename without extension, I.e.

     filename_without_extension = {
      displayName = _(Filename without extension),
      regexes = { "(.*?)\.[A-Za-z0-9]+$" }

    I've tested this code outside CollectiveAccess with the above filenames and it seems to match OK yet for some reason it doesn't match the idno for the objects.

  • I'd have to see the system to tell what wrong. If things don't line up exactly it won't work at all.
  • Hi Seth. As far as I can see the idno of the existing record exactly matches the filename (minus the extension) of the media I'm trying to import but it says it can't find a match. I could give you access to the system if that helps?
  • edited March 24

    OK, I tried again with a 1.6.3 installation and get the same result. I'm trying to import one media file to match against an existing idno.

    idno = DSYHC.2003.4.1

    media filename = DSYHC.2003.4.1.jpg

    My import settings are as above, i.e.

    • Import Mode = Import only media which can be matched with existing records
    • Object Identifier = Set object identifier to file name without extension

    It still fails to match. The debug log file is attached here.

    Any ideas? Thanks

Sign In or Register to comment.