Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Display Media Represntation Specific Data

Is it possible, on the Details page, to display information, such as a description, specific to the image that is being currently displayed.

I have tried a couple of different ways and each time only the information of the first image will display no matter what image is currently the main image.

Comments

  • Hi wbrown,

    Your detail.conf configuration file should have an option called representationViewerCaptionTemplate that will allow you to display media specific metadata using the display template syntax.
  • Thanks found the option and it worked, although is there anyway to use double quotes? In testing so far using double quotes seems to break everything, but for our implementation we need the use of a regular expression which will not work in single quotes.

    <unit relativeTo='ca_object_representations'>
    <if rule="^preferred_labels !~ /^(\[BLANK\]|Rep)$/">
    <div id='mediaInfo'>^ca_object_representations.preferred_labels<br/><ifdef code='ca_object_representations.description'>Description:<br/>^ca_object_representations.description</ifdef></div>
    </if>
    </unit>

    This is what we are trying to get functioning, But the double quotes in the if statement seem to be the problem.
Sign In or Register to comment.