Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Media size setting

Uploading JPG images ("Representations") works for me if they are <2Mb but otherwise Providence quickly gives up - but with no error message.  There must be a setting somewhere because the underlying MySQL LONGBLOB allows for 4Gb, 

Could someone suggest where the setting might be?

Comments

  • In you server's php.ini file you'll need to change the upload file size limits updating two settings:

    upload_max_filesize
    post_max_size

    The former sets the maximum upload size. The latter sets the maximum size for a POST request. You can set them to the same value, but if you set them differently make sure post_max_size is greater than upload_max_filesize
  • edited November 15
    Fixed. Having switched to Apache from NGINX, it turns out that a separate php.ini is installed for apache2 i.e.

     /etc/php/7.0/apache2/php.ini
    in place of
     /etc/php/7.0/php.ini

    I was aware of these settings but had been editing the wrong file. Doh.
Sign In or Register to comment.