Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Objects not appearing in Pawtucket 2 Collection Browse

edited February 5 in Troubleshooting
Hi,
I am running a new version of Providence with Pawtucket2.  All of a sudden, new objects added in Providence and assigned to a particular collection there don't appear in a Pawtucket2 Collection Browse for that collection.  On a search for the collection on the Providence side, they are listed though.   In Pawtucket, however an advanced search brings up the object, so I know the public settings are fine and the object is publicly visible.  I have been adding new objects without issue until recently when this issue all of a sudden arose.  I reindexed the database which is having no effect.  Any ideas why this might be happening?  

I am not sure whether this is related, but in my server error log, I am seeing the following error.  I am running PHP7.
PHP Warning: A non-numeric value encountered in [my website]/pawtucket2/app/controllers/SearchController.php

Thanks!

Comments

  • edited February 5
    Ok - all of a sudden the object appeared.... Any reason for the delayed appearance in the collection browse?  Perhaps the software caching, PHP caching?  I know I have Pawtucket2 running out of same folder as a Drupal 8 site, so maybe there is a caching effect there.
  • The browse results can be cached. That might have been the issue. 

    What was the line # of that warning you got?
  • Hi Seth - Looks like line 386.  
Sign In or Register to comment.