Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

data import: entitySplitter relationships parameter

Hello all! 

I'm creating an import map, and have a question about the entitySplitter. 

I'm importing exhibitions, and also splitting entities and places. On my test imports I noticed that the entities were also being connected to places, but without a relationshipType. I'm trying to define that relationship type within the import map, and was attempting to do it through the entitySplitter with a relationships parameter. I haven't had much luck, unfortunately. I'm wondering if I'm going about this the wrong direction, or if I'm fundamentally misunderstanding something about the parameter. I'm also not sure if I'm just trying to do too much with one import, and perhaps I should create the relationships separately? 

There are a number of skipped lines, those are part of the original flat file database, but aren't relevant to this import. 

Any assistance is greatly appreciated!



  • Hi Julia,

    It looks like your entitySplitters are missing the relationshipType setting for the Place relationships. They do have relationshipTypeDefault set, which would explain with entities have place relationships in your test imports.

    Try the following (in bold), adding whatever relationship type code is relevant:

        "delimiter": ",",
        "entityType": "individual",
        "relationshipType": "artist",
        "skipIfValue": ["unknown"],
        "attributes": {
            "idno": "%"
        "relationshipTypeDefault": "artist",
        "matchOn": ["labels", "idno"],
        "relationships": [{
            "relatedTable": "ca_places",
            "preferredLabels": "^8",
            "placeTypeDefault": "location",
            "relationshipType": "your_relationship_type_code",
            "relationshipTypeDefault": "exhibited",
            "matchOn": ["labels", "idno"],
            "placeHierarchy": "places"
  • Thanks so much, but unfortunately this doesn't seem to be working. I've double checked my JSON and relationshipTypes idnos, but there seems to be something else I'm missingHere's what I have right now: 

     "entityType": "individual",
    "relationshipType": "curator",
     "skipIfValue": ["unknown"],
     "attributes": {"idno":"IND.%" },
     "matchOn": ["labels", "idno"],
         "relationships": [{
            "relatedTable": "ca_places",
            "preferredLabels": "^8",
            "placeTypeDefault": "location",
            "relationshipType": "curated",
            "relationshipTypeDefault": "curated",
            "matchOn": ["labels", "idno"],
            "placeHierarchy": "places"

  • What specific aspect of the splitter is not working? Let me know what the intended behavior is supposed to be vs. the actual behavior and I will take a look.
Sign In or Register to comment.